Unsupported Operating System Message Displays in Mac OS X 10.8 Mountain Lion | HP


This video will show what to do if you get an “Unsupported Operating System” message during install on a Mac running OS X 10.8 Mountain Lion. If you see the “Unsupported Operating System” message during install, you need to download and install the latest HP installation software. The following steps will guide you to the latest software for Mac OS X 10.8 Mountain Lion. From your Mac, open the browser of your choice. Type www.hp.com/support into the browser’s address bar and then press Enter on your keyboard. Click where you live on the map. For this video, we’ll select North America. Select the country where you live and language from the list shown. We selected United States and English. Next, click the Drivers & Software option. In the Enter a product name/number text box, type in your model number. For the purposes of this video we are using the HP Photosmart 7510 c311a. With the model number entered, click Search or press Enter on your keyboard. If you type in a portion of your model number, like 7510 or c311 instead of Photosmart 7510 c311a, you might have to choose your printer from a list. If you type in your complete model number it will take you directly to your printer’s software page. Click the Select your operating system drop-down list. Click on Mac OS X and then click Next. Click “Driver – Product Installation Software.” Choose the latest version of the software and begin installing the software. Since the download and installation instructions are different depending on your printer model, we will not show those instructions here. You can find additional helpful videos at hp.com/supportvideos and on our YouTube channel, youtube.com/hpprintersupport.

Leave a Reply

Your email address will not be published. Required fields are marked *